Curate By

  • Theme
  • Sector
  • Channel
  • Show All

Connect to


Meltdown & Spectre: The security flaw that affects us all

This week, Google's in-house security team known as Project Zero announced details of multiple major security flaws affecting processors dating back as far as 1995 from Intel, AMD and ARM CPUs, regardless of the operating system – so there won’t be anyone unaffected here. These flaws have been named as Meltdown: and Spectre:
These vulnerabilities could potentially allow an attacker to read arbitrary memory locations on a server,  workstation or any device, thus leaking highly sensitive information such as passwords, private data or customer data. This affects both physical and virtual servers, workstations and devices.
Companies including Microsoft, Amazon, Apple and Google are in the process of issuing patches* which should be available in the next few days, with some beta versions already available for testing. Patches are now available for some Windows and Linux builds. For Linux these are now making their way into downstream distributions.
*Patches are normally small (but sometimes large) updates to the software or data that are meant to improve the solution, often through performance or security improvements, but also could be bug fixes to resolve a problem.
Whilst it may sound crazy, this also affects tablets and mobiles. You’ll see press coverage aimed at Intel and Apple as that will generate clicks for the articles, but it will literally affect everyone.
Performance Impact
As the vulnerability is due to a physical hardware design flaw, patches to fix these vulnerabilities require extensive changes to the operating system kernels. These fixes unfortunately have a significant performance impact.
It has been reported that systems can expect a 5-30% performance drop depending on the nature of the workload. There are some reports of up to 60% in certain test cases. This may impact website performance, causing longer page load times. Monitoring reports will be reviewed to indicate what impact has been identified, and your Digital Planner and Support team will work with you to identify where this can be recovered.
Public Information
The vulnerabilities have the following CVE codes:
CVE-2017-5753: Variant 1, bounds check bypass
CVE-2017-5715: Variant 2, branch target injection
CVE-2017-5754: Variant 3, rogue data cache load
Additional information can also be found here:
Managed Hosting
Lab clients with Support and Maintenance will be getting these patches applied as quickly as possible, and where Lab don’t manage or assist with hosting - we will be available to work with our clients to ensure everything is done correctly. This is regardless of platform, so everyone will need it.
Lab normally operate a strict deployment window for updates and patches, but these may need to be escalated to get the patches deployed as quickly as possible.
If you have any concerns, please reach out to the Lab Support Team, or your Digital Planner, who can organise a discussion.
Hear more from the DMA

Please login to comment.